packages/libs/yajl/patches/100-link-reformatter-uclibc-libm.patch
Charles Southerland f3eeede823 yajl: add yajl
Adds YAJL (Yet Another JSON Library), a C library for parsing JSON.
Includes patches for uClibc support.
Improved from version used internally at Who's On My WiFi since Feb 2014.
Adds myself as maintainer.

Signed-off-by: Charles Southerland <charlie@stuphlabs.com>
2015-07-29 09:46:58 -05:00

11 lines
319 B
Diff

--- a/reformatter/CMakeLists.txt
+++ b/reformatter/CMakeLists.txt
@@ -26,7 +26,7 @@
ADD_EXECUTABLE(json_reformat ${SRCS})
-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
+TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
# copy the binary into the output directory
GET_TARGET_PROPERTY(binPath json_reformat LOCATION)