On buildbots, the building directory seems to be not a subdir of a git repo, so a variable expands into an empty string which in turn results in a syntax error: --snip-- -- Looking for in6addr_any - found -- Found Git: /data/bowl-builder/arm_cortex-a5/build/sdk/staging_dir/host/bin/git (found version "2.1.4") fatal: Not a git repository (or any parent up to mount point /data) Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set). CMake Error at CMakeLists.txt:114 (if): if given arguments: "STREQUAL" "/data/bowl-builder/arm_cortex-a5/build/sdk/build_dir/target-arm_cortex-a5_musl_eabi/libiio-0.11" Unknown arguments specified -- Configuring incomplete, errors occurred! --snap-- The patch quotes the if arguments and thus fixes the build. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
11 lines
429 B
Diff
11 lines
429 B
Diff
--- a/CMakeLists.txt 2017-10-23 22:24:46.000000000 +0200
|
|
+++ b/CMakeLists.txt 2017-11-18 20:31:27.943838662 +0100
|
|
@@ -111,7 +111,7 @@
|
|
OUTPUT_STRIP_TRAILING_WHITESPACE
|
|
)
|
|
|
|
- if (${LIBIIO_GIT_REPO} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
|
|
+ if ("${LIBIIO_GIT_REPO}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
|
|
execute_process(
|
|
COMMAND ${GIT_EXECUTABLE} rev-parse --short HEAD
|
|
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|