packages/lang/perl/patches/110-always_use_miniperl.patch
Marcel Denia 3aaaede7b2 perl: Reorganize patches
The old scheme didn't make any sense...not that there was a scheme really.

Signed-off-by: Marcel Denia <naoir@gmx.net>
2015-09-25 11:50:52 +02:00

27 lines
763 B
Diff

--- a/Makefile.SH
+++ b/Makefile.SH
@@ -315,22 +315,11 @@ MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE
!GROK!THIS!
-case "$usecrosscompile$perl" in
-define?*)
- $spitshell >>$Makefile <<!GROK!THIS!
-# Macros to invoke a copy of our fully operational perl during the build.
-PERL_EXE = perl\$(EXE_EXT)
-RUN_PERL = \$(LDLIBPTH) \$(RUN) $perl\$(EXE_EXT)
-!GROK!THIS!
- ;;
-*)
- $spitshell >>$Makefile <<!GROK!THIS!
+$spitshell >>$Makefile <<!GROK!THIS!
# Macros to invoke a copy of our fully operational perl during the build.
PERL_EXE = perl\$(EXE_EXT)
-RUN_PERL = \$(LDLIBPTH) \$(RUN) ./perl\$(EXE_EXT) -Ilib
+RUN_PERL = \$(LDLIBPTH) \$(RUN) ./miniperl\$(EXE_EXT) -Ilib
!GROK!THIS!
- ;;
-esac
$spitshell >>$Makefile <<!GROK!THIS!
# Macros to run our tests