packages/net/seafile-seahub/patches/020-Makefile-fixes.patch
Jeffery To 1d275a8f27 seafile-seahub: Update to 7.1.2, refresh patches
Other changes include:

* Package Python bytecode in seafile-seahub, add source code package
  (seafile-seahub-src)

* Instead of changing default settings, custom settings will be added to
  /etc/seafile/conf/seahub_settings.py during seafile-server setup

* Use SEAFILE_UCI_DATA_DIR, which will be added to seafile-server

* Clean up Makefile formatting

* Add myself as a maintainer

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2020-03-16 17:45:52 +08:00

36 lines
955 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,6 @@
+PYTHON ?= python
+DJANGO_ADMIN_PY ?= django-admin.py
+
PROJECT=seahub
develop: setup-git
@@ -9,22 +12,22 @@ dist: locale statici18n collectstatic
locale:
@echo "--> Compile locales"
- django-admin.py compilemessages
+ $(DJANGO_ADMIN_PY) compilemessages
@echo ""
statici18n:
@echo "--> Generate JS locale files in static/scripts/i18n"
- python manage.py compilejsi18n
+ $(PYTHON) manage.py compilejsi18n
collectstatic:
@echo "--> Collect django static files to media/assets"
rm -rf media/assets 2> /dev/null
- python manage.py collectstatic --noinput -i admin -i termsandconditions
+ $(PYTHON) manage.py collectstatic --noinput -i admin -i termsandconditions
compressstatic:
@echo "--> Compress static files(css) to media/CACHE"
rm -rf media/CACHE 2> /dev/null
- python manage.py compress
+ $(PYTHON) manage.py compress
clean:
@echo '--> Cleaning media/static cache & dist'