Changes since oldpackages: - updated to 1.0.25 * most of openwrt patches are upstreamed now - cups dependency was completely removed - small musl patch - small uclibc patch - removed link to extra libraries in libsane (used only for preload backends) - sane-libs and sane-backends merged and exploded into individual packages for each backend: * libsane for sane library (which backends should dep on) * sane-daemon for saned daemon * sane-xxx for sane backend for xxx ** each backend has its own custom dep libraries * sane-backends-all (with no files) that deps on all backends * sane-qcam is only available for x86/x86_64 ** other archs does not implement inb/outb (at least in musl) Now it is possible to use SANE with much less FS space (KB instead of MB). Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
38 lines
1.1 KiB
Diff
38 lines
1.1 KiB
Diff
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -279,6 +279,9 @@ dnl ************************************
|
|
dnl Checks for library functions
|
|
dnl ***********************************************************************
|
|
|
|
+dnl Check mkostemp (missing in uclibc)
|
|
+AC_CHECK_FUNC(mkostemp)
|
|
+
|
|
dnl Define SOCKET_LIB, NSL_LIB, BIND_LIB, and RESOLV_LIB when required
|
|
dnl for functions we use.
|
|
AC_CHECK_FUNC(gethostbyaddr,, [AC_CHECK_LIB(bind, gethostbyaddr, BIND_LIB="-lbind")])
|
|
--- a/include/sane/config.h.in
|
|
+++ b/include/sane/config.h.in
|
|
@@ -207,6 +207,9 @@
|
|
/* Define to 1 if you have the `mkdir' function. */
|
|
#undef HAVE_MKDIR
|
|
|
|
+/* Define to 1 if you have a working `mkostemp' function. */
|
|
+#undef HAVE_MKOSTEMP
|
|
+
|
|
/* Define to 1 if you have a working `mmap' system call. */
|
|
#undef HAVE_MMAP
|
|
|
|
--- a/backend/pieusb_buffer.c
|
|
+++ b/backend/pieusb_buffer.c
|
|
@@ -112,6 +112,11 @@
|
|
#endif
|
|
#endif
|
|
|
|
+#ifndef HAVE_MKOSTEMP
|
|
+/* uclibc might not implement mkostemp GNU extension */
|
|
+#define mkostemp(template, flags) mkstemp(template)
|
|
+#endif
|
|
+
|
|
static void buffer_update_read_index(struct Pieusb_Read_Buffer* buffer, int increment);
|
|
|
|
/* READER */
|