* OPUS and Pulse can be configured nicely by default now, no longer need a local patch for that * mysql version checks fail when cross-compiling, add patch to remove them and always assume MySQL >8.0. * Package new services, communicators, ... This is a new major release. It breaks protocol compatibility with the 0.15.x versions. Please be aware that Git master is thus henceforth (and has been for a while) INCOMPATIBLE with the 0.15.x GNUnet network, and interactions between old and new peers will result in issues. 0.15.x peers will be able to communicate with Git master or 0.16.x peers, but some services - in particular GNS - will not be compatible. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -978,33 +978,13 @@ AC_ARG_WITH([mysql],
|
|
AC_CHECK_LIB([mysqlclient], [mysql_init],
|
|
[AC_CHECK_HEADERS([mysql/mysql.h],
|
|
[MYSQL_LDFLAGS="-L$MYSQL_LIBDIR"
|
|
- mysql=true],
|
|
+ mysql=true
|
|
+ mysql8=true],
|
|
[mysql=false])],
|
|
[mysql=false])])
|
|
AC_SUBST(MYSQL_LDFLAGS)
|
|
AC_SUBST(MYSQL_CPPFLAGS)
|
|
|
|
-# additional version checks for mysql
|
|
-AS_IF([test "x$mysql" = "xtrue"],
|
|
- [AC_MSG_CHECKING([for mysql version])
|
|
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
|
|
- [[include <mysql/mysql_version.h>]],
|
|
- [[#if (MYSQL_VERSION_ID < 40100)
|
|
-#error required at least version 4.1
|
|
-#endif]])],
|
|
- [mysql=true],
|
|
- [mysql=false])
|
|
- AS_IF([test "x$mysql" = "xfalse"],
|
|
- [AC_MSG_RESULT([< 4.1])
|
|
- AC_MSG_RESULT([mysql version >= 4.1 required. Will not use MySQL])])
|
|
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
|
|
- [[#include <mysql/mysql_version.h>]],
|
|
- [[#if (MYSQL_VERSION_ID < 80000)
|
|
-#error needs at least version 8.0
|
|
-#endif]])],
|
|
- [mysql8=true],
|
|
- [mysql8=false])])
|
|
-
|
|
AS_IF([test "x$mysql" = "xtrue"],
|
|
[AS_IF([test "x$mysql8" = "xfalse"],
|
|
[AC_MSG_RESULT([between 4.1 and 8.0])],
|