* update to [2021-09-27](da2501f542
)
* fixes https://github.com/aarond10/https_dns_proxy/issues/125
* restart instead of reload on interface hotplug
* fixes https://github.com/openwrt/packages/issues/16794
* produce output and log entries on service start/stop
* prevent unnecessary dnsmasq restarts if service has previously updated dnsmasq settings
* allow both named and typed dnsmasq instance settings to be updated
* update 010-fix-cmakelists patch file
Signed-off-by: Stan Grishin <stangri@melmac.net>
16 lines
592 B
Diff
16 lines
592 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -12,12 +12,7 @@ function(define_file_basename_for_source
|
|
endforeach()
|
|
endfunction()
|
|
|
|
-set(CMAKE_BUILD_TYPE "Debug")
|
|
-#set(CMAKE_BUILD_TYPE "Release")
|
|
-
|
|
-set(CMAKE_C_FLAGS "-Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
|
-set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
|
-set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
+set(CMAKE_BUILD_TYPE "Release")
|
|
|
|
if ((CMAKE_C_COMPILER_ID MATCHES GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 9) OR
|
|
(CMAKE_C_COMPILER_ID MATCHES Clang AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 10))
|