packages/utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch
Rosen Penev e495e1985e
open-vm-tools: update to 11.1.15
Refreshed patches. Reworked several of them as musl has changed.
Removed several upstreamed ones.

Added musl 1.2.0 patch which uses 64-bit time_t.

Removed -Werror as there's a redefinition warning caused by nls.mk.

Replaced glib2/host dependency with rpcsvc-proto.

Fixed compilation with full NLS.

Fixed compilation with musl 1.2.0

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-10-09 03:51:42 -07:00

44 lines
1.1 KiB
Diff

--- a/lib/nicInfo/nicInfoPosix.c
+++ b/lib/nicInfo/nicInfoPosix.c
@@ -65,6 +65,9 @@
#include <netinet/in.h>
#include <arpa/nameser.h>
#include <resolv.h>
+#if defined(__linux__) && !defined(__GLIBC__)
+#include "resolv_compat.h"
+#endif
#ifdef __linux__
# include <net/if.h>
--- a/lib/nicInfo/resolv_compat.h
+++ b/lib/nicInfo/resolv_compat.h
@@ -0,0 +1,29 @@
+#if !defined(__GLIBC__)
+/***************************************************************************
+ * resolv_compat.h
+ *
+ * Mimick GLIBC's res_ninit() and res_nclose() for musl libc
+ * Note: res_init() is actually deprecated according to
+ * http://docs.oracle.com/cd/E36784_01/html/E36875/res-nclose-3resolv.html
+ **************************************************************************/
+#include <string.h>
+
+static inline int res_ninit(res_state statp)
+{
+ int rc = res_init();
+ if (statp != &_res) {
+ memcpy(statp, &_res, sizeof(*statp));
+ }
+ return rc;
+}
+
+static inline int res_nclose(res_state statp)
+{
+ if (!statp)
+ return -1;
+ if (statp != &_res) {
+ memset(statp, 0, sizeof(*statp));
+ }
+ return 0;
+}
+#endif