packages/libs/libzdb/patches/030-openssl-1.1.patch
Eneas U de Queiroz 0f9a536daf libzdb: add compatibility with openssl 1.1
This patch merely updates the detection of the ssl library.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
2018-05-23 23:26:21 -03:00

11 lines
584 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -141,7 +141,7 @@ AC_ARG_ENABLE([openssl],
else
openssl="true"
if test "x$enableval" = "xyes"; then
- AC_CHECK_LIB([ssl], [SSL_library_init], [], [AC_MSG_ERROR([libssl not found])])
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [], [AC_MSG_ERROR([libssl not found])])
AC_CHECK_LIB([crypto], [SHA1_Init], [], [AC_MSG_ERROR([libcrypto not found])])
else
AC_MSG_CHECKING([for openssl in $enableval])