* replace 020-fix-ss-path.patch with an upstream patch 020-remove-which-dep.patch * remove 030-remove-pynotify2-dep.patch and do not install aa-notify * simplify 060-openwrt-dnsmasq-profile.patch * add two upstream patches for Python 3.10 compatibility * add an upstream patch to move from deprecated distutils which broke the build with Python 3.10+ Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
26 lines
764 B
Diff
26 lines
764 B
Diff
--- a/parser/Makefile
|
|
+++ b/parser/Makefile
|
|
@@ -351,7 +351,7 @@ install-redhat:
|
|
install -m 755 rc.apparmor.$(subst install-,,$@) $(DESTDIR)/etc/init.d/apparmor
|
|
|
|
.PHONY: install-suse
|
|
-install-suse: install-systemd
|
|
+install-suse:
|
|
install -m 755 -d $(SBINDIR)
|
|
ln -sf service $(SBINDIR)/rcapparmor
|
|
|
|
@@ -414,14 +414,6 @@ install-indep: indep
|
|
$(MAKE) -C po install NAME=${NAME} DESTDIR=${DESTDIR}
|
|
$(MAKE) install_manpages DESTDIR=${DESTDIR}
|
|
|
|
-.PHONY: install-systemd
|
|
-install-systemd:
|
|
- install -m 755 -d $(SYSTEMD_UNIT_DIR)
|
|
- install -m 644 apparmor.service $(SYSTEMD_UNIT_DIR)
|
|
- install -m 755 apparmor.systemd $(APPARMOR_BIN_PREFIX)
|
|
- install -m 755 -d $(USR_SBINDIR)
|
|
- install -m 755 aa-teardown $(USR_SBINDIR)
|
|
-
|
|
ifndef VERBOSE
|
|
.SILENT: clean
|
|
endif
|