packages/libs/glib2/patches/006-c99.patch
Rosen Penev e1d8f4fc96 glib2: update to 2.68.1
Removed two now pointless patches as they were added as options.

Switch to AUTORELEASE for simplicity.

Update MESON_ARGS.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-04-13 15:30:10 -07:00

11 lines
473 B
Diff

--- a/meson.build
+++ b/meson.build
@@ -944,7 +944,7 @@ if host_system == 'windows' and (cc.get_
glib_conf.set('HAVE_C99_SNPRINTF', false)
glib_conf.set('HAVE_C99_VSNPRINTF', false)
glib_conf.set('HAVE_UNIX98_PRINTF', false)
-elif not cc_can_run and host_system in ['ios', 'darwin']
+elif true
# All these are true when compiling natively on macOS, so we should use good
# defaults when building for iOS and tvOS.
glib_conf.set('HAVE_C99_SNPRINTF', true)