libcgroup also contains cgroup-utils, which make it very handy to work with user defined cgroups settings. It let's you define cgroups in a json like config file and execute them on the cmdline. Example: /etc/cgroup.conf: ---------------- group lowbob { cpu { cpu.shares="1"; } cpuacct { cpuset.cpu = "0" } memory { memory.limit_in_bytes = 10m; } blkio { ... } ... } ---------------- cgconfigparser -l /etc/cgroup.conf cgexec -g cpu,memory,blkio:/lowbob cpuintense-task Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
24 lines
446 B
Diff
24 lines
446 B
Diff
diff --git a/configure.in b/configure.in
|
|
index 75f4a51..f70b37c 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -193,6 +193,19 @@ if test x$with_pam = xtrue; then
|
|
header files!])])
|
|
fi
|
|
|
|
+AC_CHECK_LIB(
|
|
+ [fts],
|
|
+ [fts_open],
|
|
+ [],
|
|
+ [AC_MSG_ERROR([Cannot compile without fts!])]
|
|
+)
|
|
+
|
|
+AC_CHECK_HEADERS(
|
|
+ [fts.h],
|
|
+ [],
|
|
+ [AC_MSG_ERROR([Cannot compile without fts.h])]
|
|
+)
|
|
+
|
|
AC_CONFIG_FILES([Makefile
|
|
tests/Makefile
|
|
tests/tools/testenv.sh
|