packages/net/quassel-irssi/patches/003-use-pkgconfig-ldflags-quasselc.patch
Ben Rosser b9e5831e0f quassel-irssi: add new package
quassel-irssi is an irssi plugin that allows irssi to connect to
Quassel cores. Quassel is a distributed IRC client in which the
core can run independently and be connected to by quassel clients
over the network.

Signed-off-by: Ben Rosser <rosser.bjr@gmail.com>
2016-11-23 20:11:50 -06:00

13 lines
461 B
Diff

diff --git a/core/Makefile b/core/Makefile
index 2f81417..aa62201 100644
--- a/core/Makefile
+++ b/core/Makefile
@@ -23,7 +23,7 @@ ifndef SYSTEM_QUASSELC
QUASSELC_FLAGS:=-Ilib
else
QUASSELC_FLAGS:=$(shell pkg-config --cflags quasselc)
- LDFLAGS += -lquasselc
+ LDFLAGS += $(shell pkg-config --libs quasselc)
endif
CFLAGS+=-std=gnu11 -Wall -Wextra -Werror -g -O2 $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations