* add patches/020-cmakelists-add-version.patch (thanks @baranyaib90) to add version information to the binary and fix https://github.com/aarond10/https_dns_proxy/issues/149 * modify Makefile to add version information for the binary * rename patches/010-fix-cmakelists.patch for better readability * revert back to service restart in WAN/WAN6 trigger * update test.sh to test both init script and binary versions Signed-off-by: Stan Grishin <stangri@melmac.ca>
15 lines
656 B
Diff
15 lines
656 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -25,9 +25,9 @@ if (NOT CMAKE_INSTALL_BINDIR)
|
|
set(CMAKE_INSTALL_BINDIR bin)
|
|
endif()
|
|
|
|
-set(CMAKE_C_FLAGS "-Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
|
-set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
|
-set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
+#set(CMAKE_C_FLAGS "-Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
|
+#set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
|
+#set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
|
|
if ((CMAKE_C_COMPILER_ID MATCHES GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 9) OR
|
|
(CMAKE_C_COMPILER_ID MATCHES Clang AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 10))
|