packages/libs/postgresql/patches/700-no-arm-crc-march-change.patch
Daniel Golle bb300f0635 postgresql: update to version 15.1
https://www.postgresql.org/docs/release/15.0/
https://www.postgresql.org/docs/release/15.1/

A dump/restore using pg_dumpall or use of pg_upgrade or logical
replication is required for those wishing to migrate data from any
previous release.

Do not backport to release branch which should remain on version 14.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2023-01-14 01:47:56 +00:00

15 lines
563 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2236,9 +2236,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
# flags. If not, check if adding -march=armv8-a+crc flag helps.
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
PGAC_ARMV8_CRC32C_INTRINSICS([])
-if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
- PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
-fi
+#if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
+# PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
+#fi
AC_SUBST(CFLAGS_ARMV8_CRC32C)
# Select CRC-32C implementation.