packages/lang/python/python-twisted/patches/002-omit-tests.patch
Jeffery To 247d162e2e twisted: Rename package, fix errors
This renames the Python 2 twisted package to python-twisted, and updates
dependents (i.e. obfsproxy) to reference the updated name.

This also fixes conflicts between the Python 2 and 3 packages. Twisted
installs some scripts to /usr/bin, and previously scripts for both
packages used the same names. This adds a "3" suffix to scripts
installed by python3-twisted.

This also adds python[3]-setuptools as a dependency, as the scripts
installed to /usr/bin depend on pkg_resources (part of setuptools).

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2019-02-18 16:11:02 +08:00

37 lines
1.3 KiB
Diff

--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
# The C extensions used for Twisted.
_EXTENSIONS = [
- ConditionalExtension(
- "twisted.test.raiser",
- sources=["src/twisted/test/raiser.c"],
- condition=lambda _: _isCPython),
-
ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
sources=[
@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
- "PyHamcrest >= 1.9.0",
"attrs >= 17.4.0",
]
arguments.update(dict(
- packages=find_packages("src"),
+ packages=find_packages("src", exclude=["*.test", "*.test.*"]),
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={
- "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat"],
+ "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat", "test/*"],
},
zip_safe=False,
extras_require=_EXTRAS_REQUIRE,