packages/lang/python/python-twisted/patches/001-omit-tkconch.patch
Jeffery To 247d162e2e twisted: Rename package, fix errors
This renames the Python 2 twisted package to python-twisted, and updates
dependents (i.e. obfsproxy) to reference the updated name.

This also fixes conflicts between the Python 2 and 3 packages. Twisted
installs some scripts to /usr/bin, and previously scripts for both
packages used the same names. This adds a "3" suffix to scripts
installed by python3-twisted.

This also adds python[3]-setuptools as a dependency, as the scripts
installed to /usr/bin depend on pkg_resources (part of setuptools).

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2019-02-18 16:11:02 +08:00

18 lines
858 B
Diff

--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
@@ -144,7 +144,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
- "tkconch = twisted.conch.scripts.tkconch:run",
"trial = twisted.scripts.trial:run",
"twist = twisted.application.twist._twist:Twist.main",
"twistd = twisted.scripts.twistd:run",
--- a/src/twisted/python/twisted-completion.zsh
+++ b/src/twisted/python/twisted-completion.zsh
@@ -1,4 +1,4 @@
-#compdef twist twistd trial conch cftp ckeygen pyhtmlizer tkconch
+#compdef twist twistd trial conch cftp ckeygen pyhtmlizer
#
# This is the ZSH completion file for Twisted commands. It calls the current
# command-line with the special "--_shell-completion" option which is handled