packages/lang/python/python-requests/patches/0002-idna-dependency-bump.patch
Rosen Penev b360f25d6c python-requests: split up patches into two files
quilt cannot handle two patches in one file. It ends up merging them
and removing the description from the second. To avoid this, split into
two.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-02-15 20:38:11 -08:00

25 lines
687 B
Diff

From d3e00a4958af046879f24de365d5589d861ea6ef Mon Sep 17 00:00:00 2001
From: Naor Livne <naorlivne@gmail.com>
Date: Tue, 5 Jan 2021 16:31:15 +0200
Subject: [PATCH 2/2] Update setup.py
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
---
setup.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,8 @@ packages = ['requests']
requires = [
'chardet>=3.0.2,<5',
- 'idna>=2.5,<4',
+ 'idna>=2.5,<3 ; python_version < "3"',
+ 'idna>=2.5,<4 ; python_version >= "3"',
'urllib3>=1.21.1,<1.27',
'certifi>=2017.4.17'