packages/libs/glib2/patches/004-no-distutils.patch
Rosen Penev 0f0a5187a6
glib2: update to 2.65.1
Add a small hack to glib2 to avoid using proxy-intl and break
compilation under uClibc-ng.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-08-17 15:10:42 -07:00

20 lines
742 B
Diff

--- a/meson.build
+++ b/meson.build
@@ -2168,16 +2168,10 @@ endif
glib_conf.set('HAVE_PROC_SELF_CMDLINE', have_proc_self_cmdline)
-python = import('python').find_installation('python3')
+python = 'python3'
# used for '#!/usr/bin/env <name>'
python_name = 'python3'
-python_version = python.language_version()
-python_version_req = '>=3.5'
-if not python_version.version_compare(python_version_req)
- error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
-endif
-
# Determine which user environment-dependent files that we want to install
have_bash = find_program('bash', required : false).found() # For completion scripts
have_sh = find_program('sh', required : false).found() # For glib-gettextize