This is to make explicit the conditional select of libunwind is only needed for libopenvswitch. If we spill it over other packages, the generated kconfig will have recursive dependency issue. 2 new patches were made for this goal The other thing is that "+libunwind" will cause it to be built if any of the packages defined in this Makefile is enabled (y or m). This is at the moment by-design of the build system. Libunwind does not support architectures like arc. Use conditional select To avoid (libunwind) build failures like the following, checking for ELF helper width... configure: error: Unknown ELF target: arc make[3]: *** [Makefile:65: /data/openwrt/build_dir/target-arc_arc700_uClibc/ libunwind-1.3.1/.configured_68b329da9893e34099c7d8ad5cb9c940] Error 1 Things like "+PACKAGE_openvswitch-libopenvswitch:libunwind" will also result in recursive deps error for chains of 3 nodes. Kconfig construct like the following will be made config A tristate select B depends on !(C) || (x) config B tristate select C config C tristate config x bool Other changes include - Shared use of variable ovs__common_depends was removed - Ovn doc build was patched out Link: https://github.com/openwrt/packages/pull/12959#issuecomment-665021413 Reported-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
26 lines
704 B
Diff
26 lines
704 B
Diff
From cea7c74ecc4a0843f29ce1882d7876fff199a721 Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Mon, 23 Mar 2020 14:18:30 +0800
|
|
Subject: [PATCH] build: skip tests and docs
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
Makefile.am | 2 --
|
|
1 file changed, 2 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 04400e184..c12cfcd11 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -488,11 +488,9 @@ dist-docs:
|
|
|
|
|
|
include automake.mk
|
|
-include Documentation/automake.mk
|
|
include m4/automake.mk
|
|
include lib/automake.mk
|
|
include utilities/automake.mk
|
|
-include tests/automake.mk
|
|
include include/automake.mk
|
|
include third-party/automake.mk
|
|
include debian/automake.mk
|