Removed patches: * 027-bpo-43158-Use-configure-values-for-building-_uuid-ex.patch Already merged. * 029-disable-deprecation-warning.patch Packages should be patched/fixed to remove the use of distutils instead of disabling this warning. Also: * Updates PKG_LICENSE to use the correct SPDX license identifier * Fixes build for mipsel_24kc_24kf Fixes https://github.com/openwrt/packages/issues/17217. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
22 lines
845 B
Diff
22 lines
845 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -15638,7 +15638,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
|
$as_echo "$ABIFLAGS" >&6; }
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
|
$as_echo_n "checking SOABI... " >&6; }
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
|
$as_echo "$SOABI" >&6; }
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4820,7 +4820,7 @@ AC_SUBST(SOABI)
|
|
AC_MSG_CHECKING(ABIFLAGS)
|
|
AC_MSG_RESULT($ABIFLAGS)
|
|
AC_MSG_CHECKING(SOABI)
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
AC_MSG_RESULT($SOABI)
|
|
|
|
# Release and debug (Py_DEBUG) ABI are compatible, but not Py_TRACE_REFS ABI
|