packages/utils/qemu/patches/0010-no-tests.patch
Rosen Penev e28f2db374 qemu: fix compilation on 64 bit platforms
Last patch is for mips. Second is an upstream backport. First is needed
for at least musl 1.2.x

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-09-16 15:19:29 +08:00

24 lines
656 B
Diff

--- a/meson.build
+++ b/meson.build
@@ -2297,10 +2297,6 @@ specific_ss.add_all(when: 'CONFIG_BSD_US
linux_user_ss.add(files('gdbstub.c', 'thunk.c'))
specific_ss.add_all(when: 'CONFIG_LINUX_USER', if_true: linux_user_ss)
-# needed for fuzzing binaries
-subdir('tests/qtest/libqos')
-subdir('tests/qtest/fuzz')
-
# accel modules
tcg_real_module_ss = ss.source_set()
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
@@ -2780,10 +2776,6 @@ subdir('scripts')
subdir('tools')
subdir('pc-bios')
subdir('docs')
-subdir('tests')
-if gtk.found()
- subdir('po')
-endif
if host_machine.system() == 'windows'
nsis_cmd = [