One of big change is that QEMU has switched to Meson build system. That result in few changes to build scripts to fix python interpreter usage. Second change that it's not possible to select binaries to build, so now we have to build all targets at once (that require --enable-tools). Options --disable-sheepdog and --disable-vxhs was removed from qemu 6.1.0 and 6.0.0 accordingly. Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
29 lines
978 B
Diff
29 lines
978 B
Diff
From 905f3b7b6115f303f964b5aa1d3bc9bdae9d5bec Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Sat, 24 Feb 2018 13:46:31 +0800
|
|
Subject: [PATCH] pc-bios: fix compilation when $(AS) is actually gcc driver
|
|
|
|
---
|
|
pc-bios/optionrom/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/pc-bios/optionrom/Makefile
|
|
+++ b/pc-bios/optionrom/Makefile
|
|
@@ -36,7 +36,7 @@ override CFLAGS += -m32 -include $(SRC_D
|
|
endif
|
|
|
|
Wa = -Wa,
|
|
-override ASFLAGS += -32
|
|
+override ASFLAGS += $(Wa)-32
|
|
override CFLAGS += $(call cc-option, $(Wa)-32)
|
|
|
|
LD_I386_EMULATION ?= elf_i386
|
|
@@ -47,7 +47,7 @@ all: multiboot.bin linuxboot.bin linuxbo
|
|
pvh.img: pvh.o pvh_main.o
|
|
|
|
%.o: %.S
|
|
- $(call quiet-command,$(CPP) $(CPPFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@,"AS","$@")
|
|
+ $(call quiet-command,$(CPP) $(CPPFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@ -x assembler -,"AS","$@")
|
|
|
|
%.o: %.c
|
|
$(call quiet-command,$(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $@,"CC","$@")
|