packages/lang/python/python3/patches/015-abort-on-failed-modules.patch
Alexandru Ardelean 4ec5d3d62f python3: bump to version 3.6.4
Re-worked patch `003-do-not-run-distutils-tests.patch`
to reduce patch-size.

Removed `011-fix-ncursesw-definition-colisions.patch`
it is fixed upstream.

Refreshed with `make package/python3/refresh`

Resetting PKG_RELEASE to 1.
This variable was never used for pip3 & setuptools, since
VERSION is specified in the package definitions.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
2017-12-31 17:58:34 +02:00

10 lines
322 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -333,6 +333,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ if cross_compiling: sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]