packages/libs/postgresql/patches/700-no-arm-crc-march-change.patch
Daniel Golle e88747ef90 postgresql: update to 14.2
Minor release with a large number of fixes and small changes.
See release notes[1] for details.

[1]: https://www.postgresql.org/docs/release/14.2/
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2022-03-18 23:47:14 +00:00

15 lines
563 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -2127,9 +2127,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
# flags. If not, check if adding -march=armv8-a+crc flag helps.
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
PGAC_ARMV8_CRC32C_INTRINSICS([])
-if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
- PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
-fi
+#if test x"$pgac_armv8_crc32c_intrinsics" != x"yes"; then
+# PGAC_ARMV8_CRC32C_INTRINSICS([-march=armv8-a+crc])
+#fi
AC_SUBST(CFLAGS_ARMV8_CRC32C)
# Select CRC-32C implementation.