This package does not currently compile. This is needed to do so that it compiles: - fix emptying CXX variable in configure script - fix automake not generating Makefile (remove doxygen definitions) - force gnu++11 by patch, does not work with configure variable Also because of changed API in libmicrohttpd: - fix HttpServer Moreover this package does not support --disable-slp configure option anymore, remove it. Signed-off-by: Marek Behún <kabel@blackhole.sk>
19 lines
932 B
Diff
19 lines
932 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -66,14 +66,14 @@ AM_CONDITIONAL([SUPPORTS_GNU_PLUS_PLUS_1
|
|
|
|
# force us into gnu++98 mode if necessary
|
|
# If gnu++11 and gnu++98 then
|
|
-# If no unit tests, force to gnu++98
|
|
+# If no unit tests, force to gnu++11
|
|
# If unittests and cppunit < 1.14.0, force to gnu++98
|
|
# Else turn off deprecation messages for std::auto_ptr and run gnu++11
|
|
require_gnu_plus_plus_11="no"
|
|
AS_IF([test "x$ac_cv_gnu_plus_plus_11" = xyes],
|
|
[AS_IF([test "x$ac_cv_gnu_plus_plus_98" = xyes],
|
|
[AS_IF([test "x$enable_unittests" = xno],
|
|
- [CXXFLAGS="$CXXFLAGS -std=gnu++98"],
|
|
+ [require_gnu_plus_plus_11="yes"],
|
|
[PKG_CHECK_MODULES([CPPUNIT1], [cppunit < 1.14.0],
|
|
[CXXFLAGS="$CXXFLAGS -std=gnu++98"],
|
|
[PKG_CHECK_MODULES([CPPUNIT2], [cppunit >= 1.14.0],
|