This is based on the toolchain GCC, and aims to share as much of its Makefile and patches with that definition. The package requires two additional patches: (1) 003-dont-choke-when-building-32bit-on-64bit.patch, which fixes the `error: size of array 'test_real_width' is negative` error that occurs when building a 32-bit GCC on a 64-bit host. (Search the Internet for examples of this error appearing.) (2) 980-add-nostdinc++.patch, which backports a fix from 11.3.0 (11.2.0 only). Signed-off-by: W. Michael Petullo <mike@flyn.org>
46 lines
1.3 KiB
Diff
46 lines
1.3 KiB
Diff
From ea650cae26da4a8fc04f0c4666f4dd776d0b5fc0 Mon Sep 17 00:00:00 2001
|
|
From: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
|
|
Date: Sun, 14 Nov 2021 21:54:25 -0800
|
|
Subject: [PATCH] configure: define TARGET_LIBC_GNUSTACK on musl
|
|
|
|
musl only uses PT_GNU_STACK to set default thread stack size and has no
|
|
executable stack support[0], so there is no reason not to emit the
|
|
.note.GNU-stack section on musl builds.
|
|
|
|
[0]: https://lore.kernel.org/all/20190423192534.GN23599@brightrain.aerifal.cx/T/#u
|
|
|
|
gcc/ChangeLog:
|
|
|
|
* configure: Regenerate.
|
|
* configure.ac: define TARGET_LIBC_GNUSTACK on musl
|
|
|
|
Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
|
|
---
|
|
gcc/configure | 3 +++
|
|
gcc/configure.ac | 3 +++
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -30954,6 +30954,9 @@ fi
|
|
# Check if the target LIBC handles PT_GNU_STACK.
|
|
gcc_cv_libc_gnustack=unknown
|
|
case "$target" in
|
|
+ mips*-*-linux-musl*)
|
|
+ gcc_cv_libc_gnustack=yes
|
|
+ ;;
|
|
mips*-*-linux*)
|
|
|
|
if test $glibc_version_major -gt 2 \
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -6788,6 +6788,9 @@ fi
|
|
# Check if the target LIBC handles PT_GNU_STACK.
|
|
gcc_cv_libc_gnustack=unknown
|
|
case "$target" in
|
|
+ mips*-*-linux-musl*)
|
|
+ gcc_cv_libc_gnustack=yes
|
|
+ ;;
|
|
mips*-*-linux*)
|
|
GCC_GLIBC_VERSION_GTE_IFELSE([2], [31], [gcc_cv_libc_gnustack=yes], )
|
|
;;
|