This lets the Python build process set _PYTHON_HOST_PLATFORM instead of forcing an explicit value. Also: * Save the target _PYTHON_HOST_PLATFORM value during Build/InstallDev for use when building target Python packages (in python3-package.mk). * Use the (mostly) default PYTHON_FOR_BUILD value, instead patch configure to remove the platform triplet from the sysconfigdata file name. * Remove the "CROSS_COMPILE=yes" make variable (there is no indication that this variable is necessary). * Force host pip to build packages from source instead of downloading binary wheels. Previously, host pip can download universal (platform-independent) wheels but not platform-specific wheels, because of the custom _PYTHON_HOST_PLATFORM value. (Packages that do not have universal wheels would be compiled from source.) With a correct _PYTHON_HOST_PLATFORM, host pip can install platform-specific wheels as well. However, the pre-built shared object (.so) files in these wheels will have the host's platform triplet in their file names. When target Python packages are built (using the target's _PYTHON_HOST_PLATFORM), Python will not use these shared object files. By forcing host pip to build packages from source, the built shared object files will not have the platform triplet in their file names. (Host Python has been patched to remove the platform triplet from file names.) This allows these packages to be used when building target Python packages. (The net effect of this complete change is that platform-dependent packages will continue to be compiled from source, while platform-independent packages will now also be compiled from source.) Signed-off-by: Jeffery To <jeffery.to@gmail.com>
80 lines
3.8 KiB
Diff
80 lines
3.8 KiB
Diff
--- a/Lib/distutils/sysconfig.py
|
|
+++ b/Lib/distutils/sysconfig.py
|
|
@@ -445,6 +445,7 @@ def _init_posix():
|
|
platform=sys.platform,
|
|
multiarch=getattr(sys.implementation, '_multiarch', ''),
|
|
))
|
|
+ name = '_sysconfigdata'
|
|
_temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
|
|
build_time_vars = _temp.build_time_vars
|
|
global _config_vars
|
|
--- a/Lib/sysconfig.py
|
|
+++ b/Lib/sysconfig.py
|
|
@@ -344,6 +344,7 @@ def get_makefile_filename():
|
|
|
|
|
|
def _get_sysconfigdata_name():
|
|
+ return '_sysconfigdata'
|
|
return os.environ.get('_PYTHON_SYSCONFIGDATA_NAME',
|
|
'_sysconfigdata_{abi}_{platform}_{multiarch}'.format(
|
|
abi=sys.abiflags,
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1460,7 +1460,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
esac; \
|
|
done; \
|
|
done
|
|
- $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
|
|
+ $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata*.py \
|
|
$(DESTDIR)$(LIBDEST); \
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
ifeq (@COMPILE_ALL_TESTS@,yes)
|
|
@@ -1618,7 +1618,7 @@ sharedinstall: sharedmods
|
|
--install-scripts=$(BINDIR) \
|
|
--install-platlib=$(DESTSHARED) \
|
|
--root=$(DESTDIR)/
|
|
- -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py
|
|
+ -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata*.py
|
|
-rm -r $(DESTDIR)$(DESTSHARED)/__pycache__
|
|
|
|
# Here are a couple of targets for MacOSX again, to install a full
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -2951,7 +2951,7 @@ $as_echo_n "checking for python interpre
|
|
fi
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $interp" >&5
|
|
$as_echo "$interp" >&6; }
|
|
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH) '$interp
|
|
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata '$interp
|
|
fi
|
|
elif test "$cross_compiling" = maybe; then
|
|
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
|
|
@@ -15213,7 +15213,7 @@ else
|
|
fi
|
|
|
|
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -75,7 +75,7 @@ if test "$cross_compiling" = yes; then
|
|
AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])
|
|
fi
|
|
AC_MSG_RESULT($interp)
|
|
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH) '$interp
|
|
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib _PYTHON_SYSCONFIGDATA_NAME=_sysconfigdata '$interp
|
|
fi
|
|
elif test "$cross_compiling" = maybe; then
|
|
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
|
|
@@ -4688,7 +4688,7 @@ fi
|
|
|
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
|
AC_SUBST(PY_ENABLE_SHARED)
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|