packages/lang/ruby/patches/100-musl.patch
Ilya Lipnitskiy 5d8d4fbbcb
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset:

  find -L package/feeds/packages/ -name patches | \
  sed 's/patches$/refresh/' | sort | xargs make

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
2021-02-20 16:02:15 -08:00

24 lines
652 B
Diff

--- a/coroutine/copy/Context.h
+++ b/coroutine/copy/Context.h
@@ -13,6 +13,7 @@
#include <string.h>
#include <stdlib.h>
#include <alloca.h>
+#include <sys/types.h>
#define COROUTINE __attribute__((noreturn)) void
--- a/configure.ac
+++ b/configure.ac
@@ -2347,7 +2347,10 @@ AS_CASE([$rb_cv_coroutine], [yes|''], [
rb_cv_coroutine=copy
],
[*], [
- rb_cv_coroutine=ucontext
+ AC_CHECK_FUNCS([getcontext swapcontext makecontext],
+ [rb_cv_coroutine=ucontext],
+ [rb_cv_coroutine=copy; break]
+ )
]
)
AC_MSG_RESULT(${rb_cv_coroutine})