isc-dhcp uses system ar tool so build fails on Darwin build host. Embedded bind lib uses system ar and ranlib tools and fails on Darwin This patch explicitly specifies ar and ranlib tools for target build Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
10 lines
505 B
Diff
10 lines
505 B
Diff
--- a/bind/Makefile.in
|
|
+++ b/bind/Makefile.in
|
|
@@ -57,6 +57,7 @@ bind1:
|
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
|
(cd ${bindsrcdir} && \
|
|
export CC=${CROSS_CC} AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
|
+ ac_cv_func_catgets=no \
|
|
./configure ${bindconfig} --disable-atomic \
|
|
--disable-kqueue --disable-epoll --disable-kqueue \
|
|
--disable-epoll --disable-devpoll --without-openssl \
|