Several size optimizations. Savings of ~68KB. Remove shared build. libwangle is only used by fbthrift. Just use the static version. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
333 B
Diff
11 lines
333 B
Diff
--- a/wangle/CMakeLists.txt
|
|
+++ b/wangle/CMakeLists.txt
|
|
@@ -9,7 +9,7 @@ cmake_minimum_required(VERSION 3.0.2)
|
|
|
|
project("wangle" VERSION 1.0.0 LANGUAGES CXX C)
|
|
|
|
-add_compile_options(-std=c++1z)
|
|
+add_compile_options(-std=c++14)
|
|
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
|
set(CMAKE_MODULE_PATH
|
|
"${CMAKE_CURRENT_SOURCE_DIR}/cmake/"
|