packages/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch
Alexandru Ardelean ca800e60b0 python: don't use libressl for host build
Fixes: https://github.com/openwrt/packages/issues/3767

Since commit:
f6e6341d89

libressl is built on the host-side.

Python picks it up [ via the openssl/* headers ] and assumes
it has SSL libs.
Compiling works fine, linking fails.
Doesn't look like it's because:
2fd5ce9488

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
2017-01-06 15:29:21 +02:00

11 lines
415 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
min_openssl_ver = 0x00907000
have_any_openssl = ssl_incs is not None and ssl_libs is not None
- have_usable_openssl = (have_any_openssl and
+ have_usable_openssl = cross_compiling and (have_any_openssl and
openssl_ver >= min_openssl_ver)
if have_any_openssl: