packages/libs/libgd/patches/100-no-cxx.patch
Rosen Penev 3e44ecbafa
libgd: Switch to CMake
Size reduced from 92878 to 91675 bytes.

CMake added CXX files. Removed those.

Removed ceill patch. ceill is not used anymore.

Removed pkgconfig patch. CMake uses a different file, which does not have
this problem.

Further size reduction to 87938 with LTO.

Removed InstallDev. CMAKE_INSTALL takes care of that.

Added WebP support.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-09-12 14:48:32 -07:00

26 lines
441 B
Diff

--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,8 +23,6 @@ SET (LIBGD_SRC_FILES
gd_io_dp.c
gd_io_file.c
gd_io_ss.c
- gd_io_stream.cxx
- gd_io_stream.h
gd_jpeg.c
gd_matrix.c
gd_nnquant.c
@@ -60,8 +58,6 @@ SET (LIBGD_SRC_FILES
gdhelpers.c
gdhelpers.h
gdkanji.c
- gdpp.cxx
- gdpp.h
gdtables.c
gdxpm.c
jisx0208.h
@@ -175,5 +171,4 @@ install(FILES
gdfonts.h
gdfontt.h
gdfx.h
- gdpp.h
DESTINATION include)