packages/utils/xfsprogs/patches/100-no-selftest.patch
Rosen Penev c9e678374a
xfsprogs: import from base
Does not seem to be appropriate there.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-05-22 16:21:41 -07:00

14 lines
409 B
Diff

--- a/libxfs/Makefile
+++ b/libxfs/Makefile
@@ -118,9 +118,9 @@ LTLIBS = $(LIBPTHREAD) $(LIBRT)
# don't try linking xfs_repair with a debug libxfs.
DEBUG = -DNDEBUG
-LDIRT = gen_crc32table crc32table.h crc32selftest
+LDIRT = gen_crc32table crc32table.h
-default: crc32selftest ltdepend $(LTLIBRARY)
+default: ltdepend $(LTLIBRARY)
crc32table.h: gen_crc32table.c
@echo " [CC] gen_crc32table"