- [PATCH 1/6] BUILD: fix "make install" to support spaces in the - [PATCH 2/6] BUG/MEDIUM: ssl: fix bad ssl context init can cause - [PATCH 3/6] BUG/MEDIUM: ssl: force a full GC in case of memory - [PATCH 4/6] BUG/MEDIUM: checks: fix conflicts between agent checks - [PATCH 5/6] BUG/MINOR: config: don't inherit the default balance - [PATCH 6/6] BUG/MAJOR: frontend: initialize capture pointers earlier Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
From 184422d39df1aa27e6ef4c1ae75177489147ec99 Mon Sep 17 00:00:00 2001
|
|
From: Arcadiy Ivanov <arcadiy.ivanov@servicemesh.com>
|
|
Date: Tue, 4 Nov 2014 07:06:13 -0500
|
|
Subject: [PATCH 1/6] BUILD: fix "make install" to support spaces in the
|
|
install dirs
|
|
|
|
Makefile is unable to install into directories containing spaces.
|
|
(cherry picked from commit 3785311e64792787de78370fa126fd806734f7fe)
|
|
---
|
|
Makefile | 14 +++++++-------
|
|
1 file changed, 7 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 707037b..9556069 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -710,19 +710,19 @@ src/dlmalloc.o: $(DLMALLOC_SRC)
|
|
$(CC) $(COPTS) -DDEFAULT_MMAP_THRESHOLD=$(DLMALLOC_THRES) -c -o $@ $<
|
|
|
|
install-man:
|
|
- install -d $(DESTDIR)$(MANDIR)/man1
|
|
- install -m 644 doc/haproxy.1 $(DESTDIR)$(MANDIR)/man1
|
|
+ install -d "$(DESTDIR)$(MANDIR)"/man1
|
|
+ install -m 644 doc/haproxy.1 "$(DESTDIR)$(MANDIR)"/man1
|
|
|
|
install-doc:
|
|
- install -d $(DESTDIR)$(DOCDIR)
|
|
+ install -d "$(DESTDIR)$(DOCDIR)"
|
|
for x in configuration architecture haproxy-en haproxy-fr; do \
|
|
- install -m 644 doc/$$x.txt $(DESTDIR)$(DOCDIR) ; \
|
|
+ install -m 644 doc/$$x.txt "$(DESTDIR)$(DOCDIR)" ; \
|
|
done
|
|
|
|
install-bin: haproxy haproxy-systemd-wrapper
|
|
- install -d $(DESTDIR)$(SBINDIR)
|
|
- install haproxy $(DESTDIR)$(SBINDIR)
|
|
- install haproxy-systemd-wrapper $(DESTDIR)$(SBINDIR)
|
|
+ install -d "$(DESTDIR)$(SBINDIR)"
|
|
+ install haproxy "$(DESTDIR)$(SBINDIR)"
|
|
+ install haproxy-systemd-wrapper "$(DESTDIR)$(SBINDIR)"
|
|
|
|
install: install-bin install-man install-doc
|
|
|
|
--
|
|
2.0.4
|
|
|