Gammu is a tool for cell phone/modem control, including send/receive SMS, phone directory and other. Signed-off-by: Vitaly Protsko <villy@sft.ru> --- Makefile | 68 +++++++++++++++++++++++++++++++ files/gammurc | 37 ++++++++++++++++ patches/001-iconv-disabling-option.patch | 51 +++++++++++++++++++++++ patches/002-no-fstack-protector.patch | 11 +++++ patches/003-cmake-cross-toolchain.patch | 43 +++++++++++++++++++ patches/010-utils-shell-fix.patch | 16 +++++++ 6 files changed, 226 insertions(+)
11 lines
410 B
Diff
11 lines
410 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -537,8 +537,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMP
|
|
# MACRO_TUNE_LINKER("-pie")
|
|
# These do not work on Windows right now
|
|
if (NOT WIN32)
|
|
- # Stack protector
|
|
- MACRO_TUNE_COMPILER("-fstack-protector")
|
|
# Mark code read only
|
|
MACRO_TUNE_LINKER("-Wl,-zrelro")
|
|
endif (NOT WIN32)
|