Add new PCI and USB drivers to flashrom.mk to disable them in other build variant.s Fix DefineConfig calls to use new config symbols, and have it only append NEED_FEATURE=yes to MAKE_FLAGS. Appending NEED_FEATURE=no would still enable the feature because upstream compares against an empty string instead of comparing to yes. Drop libusb-compat dependency as all drivers use libusb-1 now. Remove upstreamed patch 010-add-arc.patch. Rework 0001-fix_internal_bitbang.patch, give it a correct prefix and more descriptive name. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
18 lines
758 B
Diff
18 lines
758 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -424,15 +424,6 @@ endif
|
|
override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
|
|
override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null | grep -v '^\#'))
|
|
|
|
-# Disable the internal programmer on unsupported architectures (everything but x86 and mipsel)
|
|
-ifneq ($(ARCH)-little, $(filter $(ARCH),x86 mips)-$(ENDIAN))
|
|
-ifeq ($(CONFIG_INTERNAL), yes)
|
|
-UNSUPPORTED_FEATURES += CONFIG_INTERNAL=yes
|
|
-else
|
|
-override CONFIG_INTERNAL = no
|
|
-endif
|
|
-endif
|
|
-
|
|
# PCI port I/O support is unimplemented on PPC/MIPS/SPARC and unavailable on ARM.
|
|
# Right now this means the drivers below only work on x86.
|
|
ifneq ($(ARCH), x86)
|