packages/libs/jose/patches/010-whole.patch
Rosen Penev c61b70918b jose: fix static library usage
When libjose is built statically, it must use --whole-archive as it uses
GCC's constructor attribute to initialize itself.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2022-09-18 23:19:31 -07:00

10 lines
212 B
Diff

--- a/cmd/meson.build
+++ b/cmd/meson.build
@@ -22,6 +22,6 @@ executable(meson.project_name(),
'alg.c',
'fmt.c',
dependencies: jansson,
- link_with: libjose,
+ link_whole: libjose,
install: true
)