Update rtorrent to 0.9.6. Update patches. Disable ipv6 in rtorrent, as ipv6 is disabled also in libtorrent. Libtorrent compilation has been broken since #1181 got merged and ipv6 got enabled. Users have seen issues like #1316 and #1804 IPv6 support in libtorrent & rtorrent master is not complete. Instead there is a separate ipv6 branch, which still needs some cleanup before mainstream use. See discussion at https://github.com/rakshasa/rtorrent/issues/59#issuecomment-56651538 So, it makes no sense to use ipv6 with the master branch. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
30 lines
895 B
Diff
30 lines
895 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 9, api version)
|
|
|
|
AM_INIT_AUTOMAKE
|
|
AC_CONFIG_HEADERS(config.h)
|
|
-AM_PATH_CPPUNIT(1.9.6)
|
|
|
|
AC_PROG_CXX
|
|
AC_PROG_LIBTOOL
|
|
--- a/scripts/common.m4
|
|
+++ b/scripts/common.m4
|
|
@@ -153,7 +153,7 @@ dnl Need to fix this so that it uses t
|
|
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
|
AC_MSG_CHECKING(for execinfo.h)
|
|
|
|
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
|
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
#include <execinfo.h>
|
|
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
|
|
])],
|
|
@@ -168,7 +168,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
|
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
|
|
AC_MSG_CHECKING(the byte alignment)
|
|
|
|
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
|
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
#include <inttypes.h>
|
|
int main() {
|
|
char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
|