packages/libs/glib2/patches/006-c99.patch
Rosen Penev 85d66757b0
glib2: use normal format functions
These meson checks rely on being able to run binaries. Just force them
on. Reduces compiled size.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-12-12 12:30:13 -08:00

11 lines
473 B
Diff

--- a/meson.build
+++ b/meson.build
@@ -923,7 +923,7 @@ if host_system == 'windows' and (cc.get_
glib_conf.set('HAVE_C99_SNPRINTF', false)
glib_conf.set('HAVE_C99_VSNPRINTF', false)
glib_conf.set('HAVE_UNIX98_PRINTF', false)
-elif not cc_can_run and host_system in ['ios', 'darwin']
+elif true
# All these are true when compiling natively on macOS, so we should use good
# defaults when building for iOS and tvOS.
glib_conf.set('HAVE_C99_SNPRINTF', true)