packages/net/uwsgi-cgi/patches/020-uwsgiconfig-system-python3.patch
Daniel F. Dickinson c387d0923c uwsgi-cgi: use python3 hostpkg not system python3
On a Debian system without python3-distutils install, uwsgi-cgi was
failing to build because it couldn't import sysconfig from distutils.
OpenWrt packages should be using the OpenWrt python not the system
python. In addition we need to use python3 not python2, even when
both are available.

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
2019-08-27 03:50:47 -04:00

10 lines
261 B
Diff

Index: uwsgi-2.0.18/Makefile
===================================================================
--- uwsgi-2.0.18.orig/Makefile
+++ uwsgi-2.0.18/Makefile
@@ -1,4 +1,4 @@
-PYTHON := python
+PYTHON ?= python3
all:
$(PYTHON) uwsgiconfig.py --build $(PROFILE)