packages/net/pdns/patches/100-lua-hpp.patch
James Taylor 6320a3b9cb pdns: add package
Maintainer: me

Compile tested: armv7l, OpenWRT SDK
Run tested: armv7l Linksys WRT1900ACS, OpenWrt SNAPSHOT, r9987-655fff1571 -
confirmed PowerDNS server links correctly against libraries. I'm unable to test
all the backend modules as I don't have suitable backing stores set up for each.

Description:
PowerDNS is a versatile nameserver which supports a large number of different
backends ranging from simple zonefiles to relational databases and load
balancing/failover algorithms. PowerDNS tries to emphasize speed and security.

This commit includes the authoritative nameserver, backends and additional tools

https://www.powerdns.com/auth.html

Signed-off-by: James Taylor <james@jtaylor.id.au>
2019-06-14 20:34:59 +10:00

60 lines
1.1 KiB
Diff

--- a/pdns/Makefile.am
+++ b/pdns/Makefile.am
@@ -54,7 +54,8 @@
bindparser.h \
named.conf.parsertest \
delaypipe.hh delaypipe.cc \
- pdns.service.in
+ pdns.service.in \
+ lua_hpp.mk
BUILT_SOURCES = \
bind-dnssec.schema.sqlite3.sql.h \
@@ -109,6 +108,12 @@
endif
+if !HAVE_LUA_HPP
+BUILT_SOURCES += lua.hpp
+nodist_pdns_server_SOURCES = lua.hpp
+CLEANFILES += lua.hpp
+endif
+
EXTRA_PROGRAMS = \
calidns \
comfun \
@@ -1303,3 +1305,7 @@
pdns.service \
pdns@.service
endif
+
+if !HAVE_LUA_HPP
+include lua_hpp.mk
+endif
--- /dev/null
+++ b/pdns/lua_hpp.mk
@@ -0,0 +1,6 @@
+lua.hpp:
+ $(AM_V_GEN)echo 'extern "C" {' > $@
+ @echo '#include "lua.h"' >> $@
+ @echo '#include "lualib.h"' >> $@
+ @echo '#include "lauxlib.h"' >> $@
+ @echo '}' >> $@
--- a/modules/luabackend/Makefile.am
+++ b/modules/luabackend/Makefile.am
@@ -15,5 +15,15 @@
slave.cc \
supermaster.cc
+if !HAVE_LUA_HPP
+BUILT_SOURCES = lua.hpp
+nodist_libluabackend_la_SOURCES = lua.hpp
+CLEANFILES = lua.hpp
+endif
+
libluabackend_la_LDFLAGS = -module -avoid-version
libluabackend_la_LIBADD = $(LUA_LIBS)
+
+if !HAVE_LUA_HPP
+include ../../pdns/lua_hpp.mk
+endif