packages/net/frr/patches/007-fix_memory_sanitizer_test.patch
Lucian Cristian df6263b9e6 frr: add missing build options
and some backports in fixing ramips target

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
2019-11-15 21:26:07 +02:00

28 lines
1,020 B
Diff

From 65209e4fbf30d09dda89aa4b1d831461506848d7 Mon Sep 17 00:00:00 2001
From: Rafael Zalamena <rzalamena@opensourcerouting.org>
Date: Tue, 8 Oct 2019 20:47:38 -0300
Subject: [PATCH] configure.ac: fix memory sanitizer test
We should test for `-fsanitize=memory` instead of `-fsanitize=thread`
when enabling memory sanitizer. While here, fix the error message.
Signed-off-by: Rafael Zalamena <rzalamena@opensourcerouting.org>
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 88f1c4f627..730e2ae6f0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -328,8 +328,8 @@ if test "$enable_thread_sanitizer" = "yes"; then
])
fi
if test "$enable_memory_sanitizer" = "yes"; then
- AC_C_FLAG([-fsanitize=thread -fPIE -pie], [
- AC_MSG_ERROR([$CC does not support Thread Sanitizer.])
+ AC_C_FLAG([-fsanitize=memory -fPIE -pie], [
+ AC_MSG_ERROR([$CC does not support Memory Sanitizer.])
], [
SAN_FLAGS="-fsanitize=memory -fPIE -pie"
])