packages/net/rp-pppoe/patches/110-Makefile.patch
Daniel Dickinson 847706ba5a rp-pppoe: Add back from oldpackages with build fixes and enhanced packaging
Add back from oldpackages with fixes for build errors and UCIfication
(for LuCI app submitted in a related PR (against LuCI repo)).

NOTE: Untested packages have been marked with @BROKEN.  This can
be undone of others report success with the sniffer

Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
2016-05-23 04:19:19 -04:00

11 lines
452 B
Diff

--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -71,7 +71,7 @@ pppoe-sniff: pppoe-sniff.o if.o common.o
@CC@ -o $@ $^ $(LDFLAGS)
pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@
- @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS) -Llibevent -levent
+ @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS)
pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o
@CC@ -o $@ $^ $(LDFLAGS)