packages/lang/python/python3/patches/025-choose-python-config-version.patch
Jeffery To d63664a5e7
python3: Update to 3.10.1, refresh/remove patches
Removed patches:
* 027-bpo-43158-Use-configure-values-for-building-_uuid-ex.patch
  Already merged.
* 029-disable-deprecation-warning.patch
  Packages should be patched/fixed to remove the use of distutils
  instead of disabling this warning.

Also:
* Updates PKG_LICENSE to use the correct SPDX license identifier
* Fixes build for mipsel_24kc_24kf

Fixes https://github.com/openwrt/packages/issues/17217.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2022-01-05 16:10:01 +08:00

11 lines
421 B
Diff

--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1643,7 +1643,7 @@ python-config: $(srcdir)/Misc/python-con
@ # On Darwin, always use the python version of the script, the shell
@ # version doesn't use the compiler customizations that are provided
@ # in python (_osx_support.py).
- @if test `uname -s` = Darwin; then \
+ @if test "$(USE_PYTHON_CONFIG_PY)" = 1; then \
cp python-config.py python-config; \
fi