packages/libs/libudev-zero/patches/0005-Makefile-add-stub-symbol-versioning.patch
Florian Eckert 0c66639a28 libudev-zero: backport latest changes to fix blocking on devices scan
This change added the latest upstream changes since version 1.0.0.

When using the smart plugin from collectd, there are problems with the
function udev_enumerate_scan_devices. This function is blocked and no
longer returns. Backporting the latest fixes from libudev-zero solves
the problem.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
2022-03-16 19:46:41 -07:00

28 lines
849 B
Diff

From 000ff7bf2fa463ea99afaea8503c2ed9f8a1852c Mon Sep 17 00:00:00 2001
From: illiliti <illiliti@protonmail.com>
Date: Wed, 8 Sep 2021 21:44:45 +0300
Subject: [PATCH 05/15] Makefile: add stub symbol versioning
Fixes: #38
---
Makefile | 3 ++-
libudev.sym | 1 +
2 files changed, 3 insertions(+), 1 deletion(-)
create mode 100644 libudev.sym
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,8 @@ PKGCONFIGDIR = ${LIBDIR}/pkgconfig
XCFLAGS = ${CPPFLAGS} ${CFLAGS} -std=c99 -fPIC -pthread -D_XOPEN_SOURCE=700 \
-Wall -Wextra -Wpedantic -Wmissing-prototypes -Wstrict-prototypes \
-Wno-unused-parameter
-XLDFLAGS = ${LDFLAGS} -shared -Wl,-soname,libudev.so.1
+XLDFLAGS = ${LDFLAGS} -shared -Wl,-soname,libudev.so.1 \
+ -Wl,-version-script,libudev.sym
XARFLAGS = -rc
OBJ = \
--- /dev/null
+++ b/libudev.sym
@@ -0,0 +1 @@
+LIBUDEV_183 {};