Maintainer: me Compile tested: armv7l, OpenWRT SDK Run tested: armv7l Linksys WRT1900ACS, OpenWrt SNAPSHOT, r9987-655fff1571 - confirmed PowerDNS server links correctly against libraries. I'm unable to test all the backend modules as I don't have suitable backing stores set up for each. Description: PowerDNS is a versatile nameserver which supports a large number of different backends ranging from simple zonefiles to relational databases and load balancing/failover algorithms. PowerDNS tries to emphasize speed and security. This commit includes the authoritative nameserver, backends and additional tools https://www.powerdns.com/auth.html Signed-off-by: James Taylor <james@jtaylor.id.au>
25 lines
575 B
Diff
25 lines
575 B
Diff
--- a/pdns/Makefile.am
|
|
+++ b/pdns/Makefile.am
|
|
@@ -68,11 +68,9 @@
|
|
backends/gsql/gsqlbackend.gcda \
|
|
backends/gsql/gsqlbackend.gcno \
|
|
backends/gsql/gsqlbackend.gcov \
|
|
- dnsmessage.pb.cc dnsmessage.pb.h \
|
|
- pdns.conf-dist
|
|
+ dnsmessage.pb.cc dnsmessage.pb.h
|
|
|
|
noinst_SCRIPTS = pdns.init
|
|
-sysconf_DATA = pdns.conf-dist
|
|
|
|
sbin_PROGRAMS = pdns_server
|
|
bin_PROGRAMS = \
|
|
@@ -1124,9 +1122,6 @@
|
|
endif
|
|
endif
|
|
|
|
-pdns.conf-dist: pdns_server
|
|
- $(AM_V_GEN)./pdns_server --no-config --config 2>/dev/null > $@
|
|
-
|
|
testrunner_SOURCES = \
|
|
arguments.cc \
|
|
auth-caches.cc auth-caches.hh \
|