packages/utils/collectd/patches/700-disable-sys-capability-check.patch
Hannu Nyman 08d759f14a collectd: update to 5.9.0
Update collectd to version 5.9.0

* remove backported upstream patches (sensors, modbus)
* remove lua patch that has been been implemented upstream
  (See collectd PR 3144)
* refresh patches and accommodate into upstream path changes
* place the 'stations' datatype for iwinfo in alpbetically
  correct place in types.db
* add libmnl dependency to 'processes' plugin required for the
  new Linux process Delay Accounting capability.
  (Alternatively the capability & requirement might be patched away
   in Makefile.am, HAVE_LIBTASKSTATS from collectd_4ea7a572)

* new plugins (disabled): ampq1, gpu_nvidia, pcie_errors,
                          write_stackdriver, write_syslog

compile-tested: ar71xx/WNDR3700 (all plugins)
run-tested: ar71xx/WNDR3700 (selected plugins)

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
2019-06-16 22:18:04 +03:00

15 lines
429 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -531,11 +531,7 @@ if test "x$ac_system" = "xLinux"; then
[have_cpuid_h="no (cpuid.h not found)"]
)
- AC_CHECK_HEADERS([sys/capability.h],
- [have_capability="yes"],
- [have_capability="no (<sys/capability.h> not found)"]
- )
-
+ have_capability="no"
if test "x$have_capability" = "xyes"; then
AC_CHECK_LIB([cap], [cap_get_proc],
[have_capability="yes"],