packages/net/quassel-irssi/patches/003-use-pkgconfig-ldflags-quasselc.patch
Josef Schlehofer 9ed187693f
quassel-irssi: refresh patches to avoid fuzz
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
2019-09-24 20:36:09 +02:00

11 lines
376 B
Diff

--- a/core/Makefile
+++ b/core/Makefile
@@ -25,7 +25,7 @@ ifndef SYSTEM_QUASSELC
QUASSELC_FLAGS:=-Ilib
else
QUASSELC_FLAGS:=$(shell pkg-config --cflags quasselc)
- LDFLAGS += -lquasselc
+ LDFLAGS += $(shell pkg-config --libs quasselc)
endif
CFLAGS+=-std=gnu11 -Wall -Wextra -g $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations