Tang is lightweight server for binding data to network presence. --- Tang's source: https://github.com/latchset/tang Maintainer: @Tiboris Compile tested: (mips, TL-WR842N, 17.01.4, r3560-79f57e422d) **Tang requires a few other software libraries:** 1. libhttp-parser 2. xinetd's socket activation 3. jose >= 8 **Two new files compared to tang upstream:** - tangdx : configuration file for xinetd - tangdw : wrapper for tangd service - puts timestamp when service activated, and - redirects stderr to log file in /var/log/ **Removed systemd requirement** Signed-off-by: Tibor Dudlák <tdudlak@redhat.com>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
diff --git a/configure.ac b/configure.ac
|
|
index b51bb31..4b37d30 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -27,32 +27,6 @@ AC_CHECK_LIB([http_parser], [http_parser_execute],
|
|
[AC_MSG_ERROR([http-parser required!])])
|
|
|
|
PKG_CHECK_MODULES([jose], [jose >= 8])
|
|
-PKG_CHECK_MODULES([systemd], [systemd])
|
|
-
|
|
-AC_ARG_WITH([systemdsystemunitdir],
|
|
- [AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files])],
|
|
- [],
|
|
- [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
|
|
-
|
|
-AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
|
|
-
|
|
-for ac_prog in systemd-socket-activate systemd-activate; do
|
|
- AC_CHECK_PROG([SD_ACTIVATE], [$ac_prog], [$as_dir/$ac_prog], [],
|
|
- [$PATH$PATH_SEPARATOR$($PKG_CONFIG --variable=systemdutildir systemd)])
|
|
- test -n "$SD_ACTIVATE" && break
|
|
-done
|
|
-
|
|
-test -n "$SD_ACTIVATE" || AC_MSG_ERROR([systemd-socket-activate required!])
|
|
-
|
|
-AC_MSG_CHECKING([systemd-socket-activate inetd flag])
|
|
-if $SD_ACTIVATE --help | grep -q inetd; then
|
|
- SD_ACTIVATE="$SD_ACTIVATE --inetd"
|
|
- AC_MSG_RESULT([--inetd])
|
|
-else
|
|
- AC_MSG_RESULT([(default)])
|
|
-fi
|
|
-
|
|
-AC_SUBST(SD_ACTIVATE)
|
|
|
|
TANG_CFLAGS="\
|
|
-Wall \
|